The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Keyboards and Mice

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 02-12-2019, 02:49 PM
drake5000 drake5000 is offline
Registered User
 
Join Date: Mar 2018
Posts: 6
POST ID # = 993887
drake5000 Reputation: 10
Default No red colour in light after spilled water

Okay that's what happened:
1. Spilled some clean water on a keyboard
2. Removed keycaps, removed backplate
3. Dried it out and let it rest for 2 days

Now the red colour is missing from light's RGB spectrum. It literally means when I set static red the keys are dark. Blue and green works fine. Input from all keys works fine.
I start thinking tbh that it's not because of water but of bad assembling by me.
Any idea if I can fix it at home or I'm bringing it to the service center?
Reply With Quote


  #2  
Old 02-13-2019, 04:54 AM
Corsair Calico Jack's Avatar
Corsair Calico Jack Corsair Calico Jack is offline
Registered User
 
Join Date: Oct 2016
Posts: 305
POST ID # = 994019
Corsair Calico Jack Reputation: 10
Default

It sounds like you shorted the LED's when you spilled water on it. Maybe if you got the water closer to the end of the circuits connection near the lighting controller? I dunno. Always unfortunate. You can try investigating for any damaged circuits on the board if you need to take a closer look. Just follow the regular safety requirements and remember that you do this at your own risk.

You can try reinstalling the firmware in iCUE. Go to Settings and then select the K70 under Device Settings. Then select the firmware update option, and then force update. See if that corrects the issue.

If it doesn't, you can try creating a ticket. Unfortunately, water damage voids the warranty, as does disassembly, so I can't guarantee our support team can authorize the replacement. You can certainly attempt it though.
Reply With Quote


  #3  
Old 02-13-2019, 11:51 AM
drake5000 drake5000 is offline
Registered User
 
Join Date: Mar 2018
Posts: 6
POST ID # = 994067
drake5000 Reputation: 10
Default

Quote:
Originally Posted by Corsair Calico Jack View Post
It sounds like you shorted the LED's when you spilled water on it.
Thank you for the answer. Since we don't have official Corsair represented service-center in Russia I think I'm bringing it to some generic service-center.
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 03:35 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.