The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Audio

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 02-16-2017, 04:17 PM
Monk77 Monk77 is offline
Registered User
 
Join Date: Feb 2017
Posts: 10
POST ID # = 891538
Monk77 Reputation: 10
Question Corsair H2100 7.1 surround sound audio issue

I've owned the h2100 for little over a year and it's worked fantastically until recently. After receiving the message "Not enough USB controller resources" on several occasions the headset audio would cut, this prompted me to fix the issue by switching USB ports. This time, the issue did not fix and I restarted my PC. When I restarted my PC the audio was restored but now the headset sounds like it only plays 2.0 audio. I switched to several different USB ports, uninstalled the driver via the Corsair gaming headset setup and removed completely with device manager and reinstalled and still the headset will only play audio as if it was in 2.0. Switching to 7.1, 5.1 and hitting the power button by the dolby emblem changed little. The speaker symbols in the Corsair gaming headset control panel only show two speakers infront of me out 6 lighting up when I hear sound on anything other than video games. Listening to music via youtube OR itunes for example is only in 2.0 and sounds TERRIBLE compared to how it used to sound. When I launch a game, the game will be in surround and sounds fine. Is there anyway to restore 7.1 surround to my other applications?
Attached Images
File Type: png 2.0 sound.png (66.5 KB, 195 views)
Reply With Quote


  #2  
Old 02-17-2017, 07:17 AM
Toasted Toasted is offline
Registered User
 
Join Date: Apr 2011
Posts: 19,347
POST ID # = 891625
Toasted Toasted Reputation: 108
Default

Did you make any changes to the system before the issue started appearing?

Check Device Manager and make sure it is using the Corsair drivers instead of the generic Microsoft USB drivers.
Reply With Quote


  #3  
Old 02-20-2017, 01:23 AM
Monk77 Monk77 is offline
Registered User
 
Join Date: Feb 2017
Posts: 10
POST ID # = 892015
Monk77 Reputation: 10
Default

No changes to the system were made before the issue started, just the headset crashing. It seems to be using Microsoft drivers instead of the Corsair drivers and I'm unsure how to fix that issue.
Reply With Quote


  #4  
Old 02-20-2017, 04:50 AM
Toasted Toasted is offline
Registered User
 
Join Date: Apr 2011
Posts: 19,347
POST ID # = 892027
Toasted Toasted Reputation: 108
Default

Expand "Sound, video and game controllers" instead and check the driver installed for the dongle.

If the drivers are not from Corsair, You should be able to find them in the install folder in the software.
Reply With Quote


  #5  
Old 02-20-2017, 06:04 PM
Monk77 Monk77 is offline
Registered User
 
Join Date: Feb 2017
Posts: 10
POST ID # = 892130
Monk77 Reputation: 10
Default

This is what I see, I tried selecting the exact drivers from the dongle folder but it says windows detected that my driver software "Corsair gaming h2100 headset is up to date"
Attached Images
File Type: png 4bccb33e3b.png (45.8 KB, 221 views)
Reply With Quote


  #6  
Old 02-21-2017, 07:29 AM
Toasted Toasted is offline
Registered User
 
Join Date: Apr 2011
Posts: 19,347
POST ID # = 892173
Toasted Toasted Reputation: 108
Default

After rereading your post, It sounds like Virtual surround was enabled in Windows as an enhancement rather than from the Corsair drivers.

You will want to double check the speaker output (Sound>Configure) as well as the virtual surround setting under the enhancements tab.
Reply With Quote


  #7  
Old 02-21-2017, 06:42 PM
Monk77 Monk77 is offline
Registered User
 
Join Date: Feb 2017
Posts: 10
POST ID # = 892243
Monk77 Reputation: 10
Default

Could you direct me to the virtual surround setting? I'm a little lost
Attached Images
File Type: png 052e56e189.png (10.3 KB, 147 views)
Reply With Quote


  #8  
Old 02-23-2017, 06:32 AM
Toasted Toasted is offline
Registered User
 
Join Date: Apr 2011
Posts: 19,347
POST ID # = 892412
Toasted Toasted Reputation: 108
Default

If i recall correctly, There used to be an option for Virtual surround in the enhancements tab. It seems like something may have changed.

Can you plug the headset dongle back into the original USB port? (Won't have a "2 -" in Windows and see if the options returns?

You can make sure if the original entry for the headset is present by clicking View>Show hidden devices.
Reply With Quote


  #9  
Old 02-23-2017, 02:31 PM
Monk77 Monk77 is offline
Registered User
 
Join Date: Feb 2017
Posts: 10
POST ID # = 892462
Monk77 Reputation: 10
Default

I plugged it into the original port and the option is still not present. I did check the events under device manager>audio inputs and outputs>headset earphone (Corsair Gaming H2100 Headset) and came up with this if it sheds any light?
Attached Images
File Type: png ss+(2017-02-23+at+01.28.35).png (25.9 KB, 176 views)
Reply With Quote


  #10  
Old 02-23-2017, 03:37 PM
Monk77 Monk77 is offline
Registered User
 
Join Date: Feb 2017
Posts: 10
POST ID # = 892469
Monk77 Reputation: 10
Default

on the actual corsair website I was given instruction to
- Uninstall your audio drivers for the motherboard
- Disable the USB Selective Suspend in the Advanced Power Options
- Connect the headset to a different PC/Laptop

Now, obviously i've tried the first one many times, the second intruction changed nothing, and as for trying it on a new PC, I tried it on my laptop and coincidentally it sounds awful on that too.. it never used to have a problem on my laptop..
Reply With Quote


  #11  
Old 02-24-2017, 07:05 AM
Toasted Toasted is offline
Registered User
 
Join Date: Apr 2011
Posts: 19,347
POST ID # = 892563
Toasted Toasted Reputation: 108
Default

Sounds like those steps are for times where a USB headset is not working properly.

Download the previous version of the drivers and see whether the option is still present. Note: The previous version does not officially support Windows 10, but you may be able to use compatibility mode.
http://softwaredownloads.corsair.com...2.0.35.msi.zip
Reply With Quote


  #12  
Old 02-25-2017, 04:36 PM
Monk77 Monk77 is offline
Registered User
 
Join Date: Feb 2017
Posts: 10
POST ID # = 892731
Monk77 Reputation: 10
Default

I removed the drivers and installed the previous version, no changes made and the virtual surround still isn't an option
Reply With Quote


  #13  
Old 02-26-2017, 07:19 AM
Toasted Toasted is offline
Registered User
 
Join Date: Apr 2011
Posts: 19,347
POST ID # = 892814
Toasted Toasted Reputation: 108
Default

Actually, It is called Speaker Fill. I'm not too sure why the H2100 is not showing the option as the V2000 does.

In Sound, Can you press configure when the headset is selected and change it to 7.1 Surround?

You can also put in a support ticket and see if Corsair can help though i'm not sure if it is something that is supported.
https://corsair.secure.force.com/
Reply With Quote


  #14  
Old 02-26-2017, 05:07 PM
Monk77 Monk77 is offline
Registered User
 
Join Date: Feb 2017
Posts: 10
POST ID # = 892892
Monk77 Reputation: 10
Default

Configure is greyed out, and I've already posted a ticket on the website, they are not nearly as helpful with trouble shooting and very slow to respond.
Reply With Quote


  #15  
Old 02-26-2017, 05:15 PM
Wired's Avatar
Wired Wired is offline
Administrator
Wired's PC Specs
 
Join Date: Aug 2000
Posts: 32,186
POST ID # = 892893
Wired Reputation: 32
Default

What are the system specs of the two systems that you tried? Google "Not enough USB controller resources" and a lot of the results come back with USB port / controller issues. Have you tried removing all other USB items from the computer?
__________________
No, I don't work for Corsair
...you need to flow like a river...
Forum Rules
Admin of this forum / webdesignforums.net / Petri's IT Forum / The Corsair Memory Steam Group
Founder/Creator/Admin of ZE SECRET PROJECT (Coming Soon)
Reply With Quote


Reply

Tags
7.1, h2100, issue, surround sound

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 08:52 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.