The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Keyboards and Mice

 
 
Thread Tools Search this Thread Rate Thread Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 02-01-2019, 12:19 PM
Phlegon Phlegon is offline
Registered User
Phlegon's PC Specs
 
Join Date: Nov 2017
Posts: 21
POST ID # = 992182
Phlegon Reputation: 10
Default Sabre RGB USB issue

Hello
I have a major headache with this mouse.
Windows randomly do not recognize the mouse and I need to either restart my PC or unplug and plug the mouse again to make it work.
It happens like 50% of the times I boot.

Things I tried to to avail:
Changing USB ports.
Changing to High Performance Power plan in Windows settings.
Clean Installing Windows 10 x64.
Windows Fast Boot is disabled.

The issue is driving me crazy and I don't understand why in 2019 USB is still not reliable and do not work well.

Specs:
Gigabyte Z370 Gaming 7
i7-8700k
Windows 10 x64 v1809

One thing to note I also use a Corsair Strafe RGB and my keyboard is not affected by this issue. It's only the mouse that's affected.
Can someone help?
Reply With Quote


 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 10:18 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.