The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Enthusiasts Section > System Builds, Modding, Custom Components, and Picture Gallery

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 05-18-2019, 09:53 PM
KoitiR45 KoitiR45 is offline
Registered User
KoitiR45's PC Specs
 
Join Date: May 2019
Posts: 1
POST ID # = 1004944
KoitiR45 Reputation: 10
Default My Corsair HD 120's dont work...

This is probably the wrong thread and im sorry, i am new to this forum. I have a 3 pack of corsair hd 120's and here are the problems:

The provided led hub does not work. Only the 1st port works with either case fan.

None of the fans spin. They just shake in place.

The rgb lights on the fan just blink forever. They just blink and blink and the controller cant even change that.

Im not done with the build so please dont tell me what do in the corsair software.
Reply With Quote


  #2  
Old 05-18-2019, 10:40 PM
DevBiker's Avatar
DevBiker DevBiker is offline
iCue βeta Team Green
DevBiker's PC Specs
 
Join Date: Feb 2017
Location: Republic of Texas
Posts: 7,001
POST ID # = 1004952
DevBiker Reputation: 83
Default

So you are using the push-button controller with the HD-120's? I'm assuming so.

Did you connect the LED cables to the fan hub in order (1-2-3-4)? They must be in order; no skipping allowed!

Did you plug the fan power control in as well? Each of the fans have 2 connections and both must be connected. One goes to the RGB Fan Hub, the other goes to the motherboard or fan controller.

Some photos of the installation would be helpful. Also, check out the RGB FAQ linked in my signature.
__________________
Please click "Edit System Specs" and fill out your system info.

This comment is provided "as-is", without warranty of any kind, express or implied, including, but not limited to, the sanity or mental fitness of the author. The author is not a Corsair employee, does not represent Corsair, and no comment should be construed as an official statement from Corsair.

Reply With Quote


  #3  
Old 05-19-2019, 04:57 AM
c-attack c-attack is online now
Registered User
c-attack's PC Specs
 
Join Date: Jun 2014
Posts: 8,297
POST ID # = 1004975
c-attack c-attack Reputation: 103
Default

Shaking without moving may indicate the fans are not getting enough starting voltage. HD fans are a PWM motor type and you need to set the BIOS fan controls to PWM mode or whatever fan controller is in use for them.
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 02:41 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.