The Corsair User Forums

The Corsair User Forums (http://www.asktheramguy.com/forums/index.php)
-   Keyboards and Mice (http://www.asktheramguy.com/forums/forumdisplay.php?f=214)
-   -   Sabre RGB USB issue (http://www.asktheramguy.com/forums/showthread.php?t=185036)

Phlegon 02-01-2019 12:19 PM

Sabre RGB USB issue
 
Hello
I have a major headache with this mouse.
Windows randomly do not recognize the mouse and I need to either restart my PC or unplug and plug the mouse again to make it work.
It happens like 50% of the times I boot.

Things I tried to to avail:
Changing USB ports.
Changing to High Performance Power plan in Windows settings.
Clean Installing Windows 10 x64.
Windows Fast Boot is disabled.

The issue is driving me crazy and I don't understand why in 2019 USB is still not reliable and do not work well.

Specs:
Gigabyte Z370 Gaming 7
i7-8700k
Windows 10 x64 v1809

One thing to note I also use a Corsair Strafe RGB and my keyboard is not affected by this issue. It's only the mouse that's affected.
Can someone help?

xMacias 02-01-2019 01:49 PM

Maybe depending on the USB port you're using, you could find more issues. Have you tried using a different port for a few days to see if it helps?

Phlegon 02-01-2019 02:19 PM

Yes I did as I wrote. Still same thing. I used all the ports of my mobo. It just keeps happening randomly at a high frequency so it doesn't take too long to appear.

SafetyRabbit 02-09-2019 09:33 PM

I'd just like add my voice to this as well. I'm having the same issue, though probably only 10% of the time.

I have two Sabre RGB mice and they both do this, on entirely different PCs. You boot your PC and have to re-plug the USB to activate the mouse. It's a shame because I like this mouse a lot and it's a pain to keep getting under my desk at work to unplug it ;)

Things I have tried without any change:
- 2 Different Sabre RGB mice
- 2 Different computers
- Different USB ports (motherboard/front of case headers/Hubs/Docks etc)
- harsh language (fun but ineffective)

Here's the common elements between the 2 computers:
- Same mouse (of course :D: )
- Windows 10 64bit
- Firmware v.2.04 on the mouse
- Both running iCUE
- Both at one point or another also had a Corsair K70 LUX Red also set up through iCUE (One still does)

I've just updated iCUE to v.3.12.118 before posting this, but even if that fixes the problem it might be a while before I know given the irregular way it fails.

SafetyRabbit 02-12-2019 03:27 AM

Can confirm that updating to iCUE v.3.12.118 did NOT fix the issue for me.


All times are GMT -4. The time now is 10:01 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.